wordpress 5.0

¿Actualitzar o no actualitzar a WordPress 5.0?

Si tens la botiga online creada amb WordPress (és a dir, utilitzes WooCommerce), t’hauràs adonat que t’ha sortit un avís indicant-te que la versió de WordPress 5.0 està disponible i et dóna l’opció de actualitzar-la.

Abans d’entrar en detall, com l’actualització no és automàtica i no hi ha cap motiu, per ara, pel que hagis de començar a treballar amb la nova versió, et recomanem que NO actualitzis la botiga. Especialment si:

– Estàs en plena campanya de Nadal o en temporada alta

– No ets expert en WordPress

Ara t’explicarem els motius.

Si tot i així decideixes actualitzar, assegura’t de tenir una còpia de seguretat completa de la teva web per si necessites tornar enrere.

Gutenberg, el nou editor en blocs

Gutenberg, el nou editor

La principal novetat que incorpora WordPress 5.0 és el nou editor Gutenberg, un editor de contingut que treballa amb blocs i que canvia, radicalment, la manera de treballar respecte a l’editor clàssic.

És molt possible que coneguis plugins com Visual Composer, Elementor o Divi, entre d’altres. Aquests són maquetadors visuals que et permeten crear pàgines personalitzades basades en blocs de contingut (imatges, textos, taules, títols, etc.). Gutenberg funciona amb la mateixa filosofia, per la qual cosa et permet crear els teus propis blocs i reutilitzar-los per a totes les teves publicacions. A més és molt visual i fàcil d’utilitzar, amb una corba d’aprenentatge bastant curta.

I si no vull utilitzar Gutenberg?

WordPress dóna la possibilitat als seus usuaris de recuperar l’editor clàssic a través d’un plugin descarregable, el Classic Editor, assegurant la seva compatibilitat amb futures versions fins al 2021.

En el cas que vulguis actualitzar a la nova versió, el podràs utilitzar conjuntament amb Gutenberg mentre et vas familiaritzant ell.

Compatibilitat amb altres plugins

El problema principal amb aquesta actualització a WordPress 5.0 és que molts dels plugins que funcionen perfectament fins a la versió anterior, deixaran de funcionar fins que els seus desenvolupadors facin les actualitzacions corresponents. I aquí és on comencen els problemes.

Si utilitzes plugins com WPML o Page Builder, els seus creadors ja han avisat que encara no són 100% compatibles. Fins i tot recomanen, igual que nosaltres, que no actualitzis fins a, almenys, finals de gener del 2019. Amb aquest temps s’espera que la nova versió sigui més estable i puguin actualitzar correctament els seus plugins perquè els problemes no recaiguin en la banda dels usuaris.

No obstant això, altres plugins importants com Akismet, Contact Form 7 o de Yoast SEO, ja han confirmat que són completament compatibles.

Com puc saber si els meus plugins són compatibles o no?

Per comprovar la compatibilitat dels teus plugins, la millor opció és visitar el web oficial del plugin i verificar si n’informa.

Una altra de les opcions és anar directament al repositori oficial de WordPress i comprovar si s’han realitzat les proves fins a la versió 5.0.

En cas de tenir plugins de pagament, el seu desenvolupador probablement ja t’hagi informat sobre la compatibilitat. En cas que no sigui així, no dubtis a posar-te en contacte amb ell i preguntar.

Hi ha més canvis en WordPress 5.0 a part de Gutenberg?

Sí, hi ha més novetats en aquesta versió, però no són tan rellevants com Gutenberg. No obstant això, te les anomenem a continuació:

– Nou tema Twenty Nineteen preparat per treballar amb Gutenberg i els seus blocs.

– Suport per a PHP 7.3. A més, des de WordPress recomanen treballar amb aquesta versió de PHP.

– Cinc noves etiquetes per a tipus de publicacions personalitzades (Custom Post Types)

– Millores en l’API REST de WordPress.

– Millores en seguretat i usabilitat.

– Altres millores menors.

 

Si necessites ajuda o vols que fem nosaltres l’actualització de la teva botiga online WordPress, no dubtis a contactar-nos.

Certificados de seguridad SSL para tiendas online

Què és un certificat SSL i per què és important per a la teva botiga online?

Un certificat SSL (Secure Socket Layer) serveix per aportar seguretat al visitant de la teva botiga online. És una manera de dir als teus clients que les seves dades a la teva botiga online estan segures perquè estàs utilitzant un protocol de seguretat que fa que aquestes viatgin per internet encriptades (o xifrades), amb la qual cosa ningú podrà llegir-les i fer-ne un mal ús.

Llegir més

woocommerce-o-prestashop

Prestashop o Woocommerce, quin escollir per a la teva botiga online?

Per fi t’has decidit a crear la botiga online! Et poses a investigar una mica i … Upps, comencen els dubtes! Una de les preguntes més freqüents acostuma a ser: és millor crear la botiga online amb Prestashop o WooCommerce? I la veritat és que la resposta no és tan directa com ens agradaria …

Per començar, explicarem breument en què consisteix cadascuna d’aquestes plataformes.

Llegir més