wordpress 5.0

¿Actualizar o no actualizar a WordPress 5.0?

Si tienes tu tienda online creada con WordPress (es decir, utilizas WooCommerce), te habrás dado cuenta de que te ha salido un aviso indicándote que la versión de WordPress 5.0 está disponible y te da la opción de actualizarla.

Antes de entrar en detalle, como la actualización no es automática y no existe ningún motivo, por ahora, por el que debas empezar a trabajar con la nueva versión, te recomendamos que NO actualices tu tienda. Especialmente si:

– Estás en plena campaña de Navidad o en temporada alta

– No eres experto en WordPress

Ahora te explicaremos los motivos.

Si aún y así decides actualizar, asegúrate de tener una copia de seguridad completa de tu web por si necesitas volver atrás.

Gutenberg, el nuevo editor en bloques

Gutenberg, el nuevo editor

La principal novedad que incorpora WordPress 5.0 es el nuevo editor Gutenberg, un editor de contenido que trabaja con bloques y que cambia, radicalmente, la manera de trabajar respecto al editor clásico.

Es muy posible que conozcas plugins como Visual Composer, Elementor o Divi, entre otros. Éstos son maquetadores visuales que te permiten crear páginas personalizadas basadas en bloques de contenido (imágenes, textos, tablas, títulos, etc.). Gutenberg funciona con la misma filosofía, por lo que te permite crear tus propios bloques y reutilizarlos para todas tus publicaciones. Además es muy visual y fácil de utilizar, con una curva de aprendizaje bastante corta.

¿Y si no quiero utilizar Gutenberg?

WordPress da la posibilidad a sus usuarios de recuperar el editor clásico a través de un plugin descargable, el Classic Editor, asegurando su compatibilidad con futuras versiones hasta el 2021. En el caso de que quieras actualizar a la nueva versión, podrás utilizarlo conjuntamente con Gutenberg mientras te vas familiarizando a él.

Compatibilidad con otros plugins

El problema principal con esta actualización a WordPress 5.0 es que muchos de los plugins que funcionan perfectamente hasta la versión anterior, dejarán de funcionar correctamente hasta que sus desarrolladores hagan las actualizaciones correspondientes. Y aquí es donde empiezan los problemas.

Si utilizas plugins como WPML o Page Builder, sus creadores ya han avisado de que aún no son 100% compatibles. Incluso recomiendan, igual que nosotros, que no actualices hasta, al menos, finales de Enero del 2019. Con este tiempo se espera que la nueva versión sea más estable y puedan actualizar correctamente sus plugins para que los problemas no recaigan en el lado de los usuarios.

No obstante, otros plugins importantes como Akismet, Contact Form 7 o Yoast SEO, ya han confirmado que son completamente compatibles.

¿Cómo puedo saber si mis plugins son compatibles o no?

Para comprobar la compatibilidad de tus plugins, la mejor opción es visitar la web oficial del plugin y verificar si informa de ello.

Otra de las opciones es ir directamente al repositorio oficial de WordPress y comprobar si se han realizado las pruebas hasta la versión 5.0.

En caso de tener plugins de pago, su desarrollador probablemente ya te haya informado sobre la compatibilidad. En caso de que no sea así, no dudes en ponerte en contacto con él y preguntárselo.

¿Hay más cambios en WordPress 5.0 a parte de Gutenberg?

Sí, hay más novedades en esta versión, pero no son tan relevantes como Gutenberg. No obstante, te los nombramos a continuación:

– Nuevo tema Twenty Nineteen preparado para trabajar con Gutenberg y sus bloques.

– Soporte para PHP 7.3. Además, desde WordPress recomiendan trabajar con esta versión de PHP.

– Cinco nuevas etiquetas para tipos de publicaciones personalizadas (Custom Post Types)

– Mejoras en la API REST de WordPress.

– Mejoras en seguridad y usabilidad.

– Otras mejoras menores.

 

Si necesitas ayuda o quieres que hagamos nosotros la actualización de tu tienda online WordPress, no dudes en contactarnos.

0 comentarios

Dejar un comentario

¿Quieres unirte a la conversación?
Siéntete libre de contribuir!

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.